Joomla

Технические требования к ПО, БД и серверам для всех версий Joomla!

Требования для поддерживаемого программного обеспечения (ПО)

Требования для Joomla! 3.x

ПОРекомендуемыеМинимумБольше информации
PHP (Magic Quotes GPC off)[1] 5.5 + 5.3.10 + http://www.php.net
Поддерживаемые базы данных (БД):
MySQL (InnoDB support required) 5.1 + 5.1 + http://www.mysql.com
SQL Server 10.50.1600.1+ 10.50.1600.1+ http://www.microsoft.com/sql
PostgreSQL 8.3.18 + 8.3.18 + http://www.postgresql.org/
Поддерживаемые веб-серверы:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 2.x + http://www.apache.org
Nginx 1.1 1.0 http://wiki.nginx.org/
Microsoft IIS[5] 7 7 http://www.iis.net

Требования для неподдерживаемого ПО

Требования для Joomla! 1.6, 1.7, & 2.5 - Поддержка окончена 31 декабря 2014

ПОРекомендуемыеМинимумБольше информации
PHP 5.4 + 5.2.4 + http://www.php.net
Поддерживаемые БД:
MySQL 5.0.4 + 5.0.4 + http://www.mysql.com
SQL Server[4] 10.50.1600.1+ 10.50.1600.1+ http://www.microsoft.com/sql
Поддерживаемые веб-серверы:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 2.x + http://www.apache.org
Nginx 1.1 1.0 http://wiki.nginx.org/
Microsoft IIS[5] 7 7 http://www.iis.net

Требования для Joomla! 1.5 - Поддержка окончена 31 декабря 2012

ПОРекомендуемыеМинимумБольше информации
PHP[3] 5.3 4.3.10 + http://www.php.net
Поддерживаемые БД:
MySQL 4.1.x + 3.23 http://www.mysql.com
Поддерживаемые веб-серверы:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 http://www.apache.org
Microsoft IIS[5] 7 6 http://www.iis.net

Требования для Joomla! 1.0 - Поддержка окончена 22 июля 2009

ПОРекомендуемыеМинимумБольше информации
PHP[3] 5.2 or 5.3 4.2 http://www.php.net
Поддерживаемые БД:
MySQL 4.1.x + 3.23 http://www.mysql.com
Поддерживаемые веб-серверы:
Apache[2]
(with mod_mysql, mod_xml, and mod_zlib)
2.x + 1.3 http://www.apache.org
Microsoft IIS[5] 7 6 http://www.iis.net

Примечания

[1] PHP 5.3.1, необходим для версии 3.0 через 3.2. В 3.3, минимум повышен до PHP 5.3.10.

[2] Для того, чтобы использовать SEO URL-адресов (ЧПУ), вы должны иметь установленным расширение mod_rewrite (обратитесь к поддержке вашего хостинга, если такое расширение отсутсвует или выключено).

[3] Не используйте PHP 4.3.9, 4.4.2 или 5.0.4. Эти релизы известны ошибками, которые будут мешать при установке. Zend Optimizer 2.5.10 для PHP 4.4 также имеет серьезные ошибки, и вы должны попросить поддержку вашего хостинга перейти на более новую версию. Joomla! 1.5.15 версии и более поздние совместимы с PHP 5.3. Обратите внимание, что библиотека OpenID не совместима с PHP 5.3.

[4] Поддержка Microsoft SQL Server была добавлена в релизе 2.5; в релизах 1.6 и 1.7 не поддерживается.

[5] Для Microsoft IIS (в зависимости от настроек), вам, возможно, потребуется следующее:

Для получения дополнительной помощи по использованию Microsoft IIS, посетите Joomla! IIS forum.

Параметры конфигурации

При установке на локальном компьютере, существует ряд пакетов, которые помогут вам получить результат быстрее, чем при отдельных установках ПО:

  • LAMP (Linux) - Большинство дистрибутивов Linux поставляются с заранее сконфигурированным сервером LAMP.
  • WAMP (Windows) - чтобы получить больше информации, посетите http://www.wampserver.com
  • MAMP (Macintosh) - чтобы получить больше информации, посетите http://www.mamp.info
  • XAMPP (Multi-platform) - Не для действующих сайтов. Чтобы получить больше информации, посетите http://www.apachefriends.org/en/xampp.html

 

Добавить комментарий


Защитный код
Обновить